SMS Registration Failing / Issues sending / receiving SMS MMS
Incident Report for Servcomm
Resolved
This incident has been resolved.
Posted Feb 07, 2023 - 08:23 PST
Monitoring
We want to provide some additional details on the scope of this issue, and what you should expect.

At the end of January, TCR released an update to their API that deprecated the auto-approval process for SMS Registration. Effective January 31, all new registrations require a manual review of the campaigns. Manual. As in humans are doing it. For every registration.

Unfortunately, this change caused our registration system to break, as it needs to conform to these new requirements. In addition to changing our SMS Registration interconnections, customers will now have to wait while their Campaign Registration is manually reviewed before they can send SMS through our network. They have published an expected timeline of 5+ business days between the time a registration request is submitted and its approval.

These changes have to be accounted for in how our portal interacts with the SMS Gateways, and is the reason for the extended resolution.
Posted Feb 01, 2023 - 16:09 PST
Identified
We are aware of an issue that is preventing SMS Registration from completing successfully.

We have determined the route cause to be related to a breaking API change made by The Campaign Registry. Unfortunately this change is not a small one, and will require some development work to accommodate. We do not have an ETA for resolution for this, but expect it to take at least a week to resolve.

We are as frustrated by this as you are, and are working as fast as possible to resolve this issue.

13:34 PST - 1 February 2023
Posted Feb 01, 2023 - 13:48 PST
This incident affected: SMS / MMS Messaging Services.