Service degradation across multiple Carrier services

Incident Report for Servcomm

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 16:07 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2026 - 13:06 PST

Investigating

Update
A fix has been deployed and we are actively monitoring the results.

The issue is on Cloudflare’s side: https://www.cloudflarestatus.com/incidents/kwy3dt82bwbt

Posted 2 hours ago. Feb 20, 2026 - 11:57 PST
Monitoring
API and SIP are back. telnyx.com website is still down.

Posted 2 hours ago. Feb 20, 2026 - 11:57 PST
Update
We are currently investigating this issue.

Posted 2 hours ago. Feb 20, 2026 - 11:37 PST
Investigating
We are currently investigating this issue.

Posted 2 hours ago. Feb 20, 2026 - 11:31 PST
Posted Feb 20, 2026 - 13:05 PST
This incident affected: SIP Services (SIP Trunk Services).